We are continuously monitoring for outages, slowdowns, or other issues. See upcoming maintenance and any incidents in progress.

Some Users May Experience Slower Performance
Incident Report for Statflo Inc
Resolved
UPDATE: The problem should be resolved. We apologize for the inconvenience and thank you for your patience and continued support. We will continue to monitor the situation.
Posted Dec 03, 2019 - 18:55 EST
Investigating
It has come to our attention that some users are experiencing slower performance today. Our team is investigating the issue and will provide an update once we've identified a potential solution.
Posted Dec 03, 2019 - 18:50 EST