We are continuously monitoring for outages, slowdowns, or other issues. See upcoming maintenance and any incidents in progress.

Some users are experiencing slower performance
Incident Report for Statflo Inc
Resolved
UPDATE: The problem should be resolved. We apologize for the inconvenience and thank you for your patience and continued support. We will continue to monitor the situation.
Posted Dec 02, 2019 - 14:36 EST
Update
UPDATE: Our Team has identified the problem and are currently working to implement the solution. We expect service to return to normal shortly.
Posted Dec 02, 2019 - 14:26 EST
Update
UPDATE: Our Team has identified the problem and are currently working to implement the solution. We expect service to return to normal shortly.
Posted Dec 02, 2019 - 14:26 EST
Update
UPDATE: Our Team has identified the problem and are currently working to implement the solution. We expect service to return to normal shortly.
Posted Dec 02, 2019 - 14:16 EST
Monitoring
We're monitoring the situation after some changes to our infrastructure.
Posted Dec 02, 2019 - 14:11 EST
Investigating
It has come to our attention that some users are experiencing slower performance today. Our team is investigating the issue and will provide an update once we've identified a potential solution.
Posted Dec 02, 2019 - 14:06 EST