Most Customers cannot access Campaigns

Incident Report for Statflo Inc

Resolved

After monitoring the situation over the past four hours, we can confirm the incident was fully resolved as of our last update.
Thank you for your patience and understanding throughout.
Posted May 06, 2025 - 15:47 EDT

Monitoring

In-app reports are updating again. We are monitoring the situation and will tackle any downstream impact.
Posted May 06, 2025 - 12:08 EDT

Update

Good news: Campaigns are fully accessible, and all users are welcome to log in again.
We've started to address downstream impacts, including updating reports.
Posted May 06, 2025 - 11:45 EDT

Update

We remain on track to restore access to Campaigns by noon ET.
Once resolved, we’ll address downstream impacts, including updating reports.

In the meantime, we recommend affected users wait until the issue is fully resolved before logging back in.
Thank you for your continued patience and understanding.
Posted May 06, 2025 - 11:17 EDT

Update

We are continuing to make progress toward full restoration. However, additional time is needed. We now expect Campaigns to be accessible again within the next 90 minutes. We appreciate your patience as we work to resolve this issue.
Posted May 06, 2025 - 10:25 EDT

Update

We are making progress towards restoring the full functionality of the app and expect Campaigns will be accessible again within 30 minutes.
Posted May 06, 2025 - 09:49 EDT

Identified

We have identified the cause of the issue, and are working on a solution to restore access to Campaigns.
Posted May 06, 2025 - 08:48 EDT

Investigating

We have identified an issue affecting most Customers, which is preventing them from accessing Campaigns.
Posted May 06, 2025 - 08:47 EDT
This incident affected: Statflo (Conversation Platform, Statflo Application).