We are continuously monitoring for outages, slowdowns, or other issues. See upcoming maintenance and any incidents in progress.

Conversations Not Functioning
Incident Report for Statflo Inc
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 09:55 EST
Monitoring
A fix has been implemented and we're currently monitoring the results.
Posted Nov 27, 2019 - 09:49 EST
Investigating
We are currently investigating conversations (SMS) not loading. We'll be providing further updates shortly.
Posted Nov 27, 2019 - 09:41 EST
This incident affected: Statflo Application (Conversation Platform).