We are continuously monitoring for outages, slowdowns, or other issues. See upcoming maintenance and any incidents in progress.

App Instability
Incident Report for Statflo Inc
Resolved
This incident has been resolved.
Posted Feb 03, 2020 - 16:27 EST
Investigating
We are currently investigating app instability across our communication products.
Posted Feb 03, 2020 - 16:11 EST
This incident affected: Statflo Application (Conversation Platform, Statflo Application).