We are continuously monitoring for outages, slowdowns, or other issues. See upcoming maintenance and any incidents in progress.

Emergency Maintenance - Nov 19, 2019
Incident Report for Statflo Inc
Resolved
The problem should be resolved. System reliability is a top priority and we apologize for the inconvenience and thank you for your patience and continued support.
Posted Nov 19, 2019 - 13:22 EST
Monitoring
We've deployed a fix and we're monitoring the situation as it's deploying across our systems. Some users will be able to access our network again. We expect full system recovery in the next 20 minutes.
Posted Nov 19, 2019 - 12:57 EST
Identified
Some systems have been restored and we expect a resolution for all users within the next 40 minutes.
Posted Nov 19, 2019 - 12:24 EST
Investigating
We're currently experiencing a system outage that requires us to perform an update. You may be logged out or may not be able to login for the next few minutes as we push this update. We’ll let you know as things change and apologize for the inconvenience.
Posted Nov 19, 2019 - 12:08 EST
This incident affected: Statflo Application (Conversation Platform, Third Party Services, Statflo Application).